impCentral and Legacy UI, and Newly-Enrolling Production device issue
Incident Report for Electric Imp
Resolved
This incident has been resolved.
Posted Jul 10, 2018 - 20:48 UTC
Update
impCentral and legacy UIs have resumed (nearly, see below) full functionality. All enrolled devices were fully operational during the incident; new enrollments would have failed.

There are a small set of production device enrollments from prior to the incident that have not yet been recreated; these will be reflected in the UI in the next few hours. Development enrollments will not be recreated.
Posted Jul 10, 2018 - 20:48 UTC
Update
We've restored data up to July 10, ~ 12:00 UTC. Additional data consistency checks and updates are ongoing.
Posted Jul 10, 2018 - 20:09 UTC
Identified
A datastore issue has caused impCentral and our legacy UI's view of devices to be corrupted; we're in the process of restoring from backup and regenerating any production work. We expect downtime for these components to be less than 30m, with some tail cleanup which should be limited in scope.
Posted Jul 10, 2018 - 19:32 UTC
This incident affected: impCentral.