Cellular provider outage
Incident Report for Electric Imp
Resolved
This incident has been resolved.
Posted Jul 14, 2020 - 14:45 UTC
Update
Over 97% of cellular devices are now restored. The provider is still working to restore the remaining devices.
Posted Jul 14, 2020 - 00:03 UTC
Update
Around 95% of cellular devices are now functional. Provider is still working to restore full connectivity.
Posted Jul 13, 2020 - 15:43 UTC
Update
Around 80% of cellular devices are now functional. The provider is still working to restore full connectivity.
Posted Jul 13, 2020 - 10:17 UTC
Update
Around 20% of cellular devices are now functional. The provider is still working to restore full connectivity; we believe this should be resolved in the next few hours.
Posted Jul 13, 2020 - 05:09 UTC
Identified
Our cellular provider suffered a very major outage at 1757 UTC on 2020/07/12; all cellular imps are affected, as were all communication paths to the provider in question.

We are seeing progress in service restoration - we can now communicate with the provider - but very little cellular traffic has returned at this point. We will continue to monitor and provide updates.

WiFi and Ethernet connected imps are unaffected.
Posted Jul 13, 2020 - 00:58 UTC
This incident affected: Cellular connectivity.